
9. ディジタルフィルタ
1. 目的

本実験の目的は, ディジタルフィルタを設計し, ディ
ジタルシグナルプロセッサを用いて実現することで,
ディジタル信号処理に関する理解を深めることである。

2. 原理

ディジタルフィルタとは, 観測信号から目的とする
信号成分を取り出す機能を持つディジタル信号処理シ

ステムである。本実験では, 連続時間信号を処理する
ディジタルフィルタを設計する問題を取り扱う。

2.1 連続時間信号のディジタル信号処理

図 9.1に連続時間信号のディジタル信号の流れを示
す。図 9.1において, A/D変換器とは連続時間信号x(t)
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図 9.1 連続時間信号のディジタル信号処理

を一定時間 T ごとにサンプリングして離散化しとびと

びの値を取る数列 {x(0), x(T ), . . .}に変換するという
処理をおこなう装置であり, D/A変換器とはディジタ
ルシグナルプロセッサによる処理の結果得られた数列

{y(0), y(T ), . . . }を連続時間信号 y(t)に変換する処理
をおこなう装置である。A/D変換の処理の流れを図9.2
に, D/A変換器の処理の流れを図 9.3に示す。
以下では, 観測信号は T = 1/fs 秒ごとにサンプリ

ングされているものとする。 このとき, fs をサンプリ

ング周波数と呼ぶ。また, サンプリング周波数の半分
の値 (fs/2)をナイキスト周波数と呼ぶ。また, x(kT ),
y(kT )などをより簡単に xk, yk などと略記する。

2.2 FIRフィルタ

FIR フィルタ (Finite Impulse Response Filter)と
は, インパルスを入力したときの出力信号が有限時間
で 0に収束するフィルタである。FIRフィルタは, 多
くの場合, 式 (9.1)のような非再帰型の差分方程式で実
現される。

yk = h0xk + h1xk−1 + · · ·+ hnxk−n (9.1)
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図 9.2 A/D変換器の処理
の流れ
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図 9.3 D/A変換器の処理
の流れ

式 (9.1)の意味は, 「時刻 kT における出力信号 yk は,
現在および過去の入力信号値 xk, xk−1, . . . , xk−nの重

み付き平均であらわされる」ということである。重み

付き平均を取るときの重み hi が FIRフィルタの係数
である。この係数のことをタップ係数と呼ぶこともあ

る。特に断らない限り, hi は実数であるものとする。

また, 式 (9.1)において, nをフィルタの次数, n + 1を
フィルタ長と呼ぶ。

2.3 FIRフィルタの周波数応答

フィルタの入力 x(t)が周波数 f [Hz]の正弦波である
場合を考える。

xk = ej2πfkT (9.2)

とする。 式 (9.2)を式 (9.1)に代入すると,

yk =
(
h0 + h1e

−j2πfT + · · ·+ hne−j2πfnT
)
ej2πfkT

(9.3)
が得られる。

G(f) = h0 + h1e
−j2πfT + · · ·+ hne−j2πfnT (9.4)

と定義する。式 (9.3)から, フィルタの出力信号 yk は,
入力信号 xkに複素数G(f)を乗じた値となることがわ
かる。よって, このフィルタの周波数応答は式 (9.3)に
よって与えられる。

以下では, フィルタの周波数応答の絶対値をゲイン
と呼ぶ。
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FIRフィルタのタップ係数 hiを適当に設定すること

で,低域通過フィルタ,高域通過フィルタ,帯域通過フィ
ルタあるいは帯域阻止フィルタなどといったいろいろ

なフィルタを設計することができる。ただし, 有限次
元の因果的なフィルタでは, 通過域の信号を完全に歪
みなく透過させ阻止域の信号は完全に遮断する理想的

な特性を持つフィルタは実現できないことが知られて

いる。また, フィルタの性能を理想的なものに近付け
れば近付けるほど, 高性能なハードウェアが必要にな
り, 必然的にコストも増大する。このため, 実際にフィ
ルタを設計する際には, 性能とコストとのトレードオ
フなどのさまざまな要素を考慮しなければならない。

3. 実験

3.1 実験課題

教官が音楽に正弦波の雑音が加算された信号の記録

されたミュージックテープを渡す。音楽の波形をスペ

クトルアナライザを用いて観測せよ。続いて, 正弦波
の雑音を消去するフィルタ (帯域阻止フィルタ)を設計
せよ。さらに, 設計されたフィルタをディジタルシグ
ナルプロセッサで動かし, 特性を測定せよ。

3.2 実験手順

この実験では, Scilab を用いて FIRフィルタを設計
し, テキサス・インスツルメンツ社の TMS320C6711
という DSPボードおよびそれに付属する開発環境で
ある Code Composer Studio を利用して DSP上で動
作するプログラムを開発し実行してから, その特性を
測定する。DSPボードの構成を図 9.4に示す。なお,こ
のDSPボードのサンプリング周波数は 8kHz である。

以下では, マウス左ボタンを 1回押して離すことを
「クリックする」とよび, マウス左ボタンを 2回連続し
て押して離すことを「ダブルクリックする」とよぶ。ま

た, マウス右ボタンを 1回押して離すことを「右クリッ
クする」とよぶ。さらに, アイコンにマウスカーソル
を合わせてクリックすることを「アイコンをクリック

する」という。また, 「メニューを選択する」とは, メ
ニューが表示されたウインドウ内で色が青くなってい

る部分を選択したいものの名前に合わせてクリックす

ることをいう。また, Windows98ではウインドウ右上
の×印をクリックするとそのウインドウのプログラム

を終了させることができることを覚えておくこと。
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図 9.4 DSPボード TMS320C6711 の構成

3.2.1 準備

コンピューターの電源を投入する前にパラレルポー

トと DSPボード を接続し, 続いて DSPボード と電
源ユニットを接続して, DSPボード 上の LEDが点灯
することを確認すること。

パソコンが起動した後に, フロッピーディスクドラ
イブにフロッピーディスクを挿入せよ。実験に必要な

ファイルはすべてあらかじめフロッピーディスク上に

用意されている。

3.2.2 雑音周波数の測定

この実験では, 消去すべき雑音の周波数がグループに
よって異なる。そこで,フィルタ設計に先立って,ミュー
ジックテープから再生される音楽を観測し, 雑音の周
波数を確定しておく必要がある。

このために, パソコン上で動作するソフトウェアス
ペクトルアナライザであるWaveSpectra1 (フリーウェ
アである)を用いる2。

WaveSpectraを起動するには, デスクトップの左端
にあるWSというアイコンをダブルクリックする。す
ると, 図 9.5のようなウィンドウがあらわれる。

1http://www.ne.jp/asahi/fa/efu/index.html
2パソコンに塔載されたサウンドカードを用いて測定をおこなう

場合, 何らかの方法でマイク入力端子のレベル較正をおこなった場
合を除き, 測定された信号の値は相対的にしか意味を持たない。ま
た, 一般にサウンドカードのノイズ対策は極めて不十分なので, 測定
値の信頼性も低い。
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続いて, パソコンのマイク入力端子とカセットテー
プレコーダのオーディオ出力端子を接続する。

カセットテープレコーダの再生ボタンを押してから

WaveSpectraの録音ボタン (図 9.5の説明を参照)を押
すと, 図 9.7のように, マイク入力端子から取得された
信号の時間波形とスペクトルが表示される。

図 9.7において観測されている信号には周波数 2kHz
の雑音が印加されているのであるが, 表示されたスペ
クトルが 2kHzの部分にピークを持つことが図から読
み取れる。

なお, スペクトルのピークが複数ある場合にも, 雑音
が周波数と振幅が一定の正弦波のときには正弦波雑音

停止 録音(測定)

設定ウインドウを開く

操作ボタンの表示切り替え

右音声,左音声切り替え

スペクトル測定値表示

スペクトルのピーク値を保持したものを表示

ＭａｉｎとＰｅａｋを重ね書きするかどうかの切り替え

スペクトル表示ウインドウ

時間波形表示ウインドウ

図 9.5 WaveSpectraの起動

パソコン背面

ファン

マイク入力端子

図 9.6 マイク入力端子

図 9.7 スペクトルが表示されたところ

に対応するスペクトルが時間か経過しても変化しない

のに対し, それ以外の信号に大層するスペクトルは時
間とともに変動するので, スペクトルの時間変化を観
察すれば, 正弦波雑音とそうでない部分を区別するこ
とができる。

3.2.3 FIRフィルタの設計

フィルタの設計には Scilabを用いる。

Scilabを起動するには,

スタート→プログラム (P)
→ Scilab 2.6 → Scilab2.6

を選択する (図 9.8)。

図 9.8 Scilabの起動

フィルタの設計にあたって, 諸君のフロッピーディス
クのフォルダ fir にあるサンプルスクリプト design.sci
を利用する。実験ではこのファイルを修正する必要が

あるのだが, 実際に修正作業をおこなう前に, まずこの
スクリプトを実行してみることにする。

このためには, Scilabのウィンドウ内で

exec(’a:\fir\design.sci’);

と入力する (図 9.9)。すると, フィルタの設計が実行さ

図 9.9 design.sciの実行
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れ。画面に設計されたフィルタの周波数応答が表示さ

れた後に, 設計されたフィルタのタップ係数がフロッ
ピーディスクのフォルダ fir に tap.txtという名前で書
き出される。

なお, フロッピーディスク上にすでに同名のファイ
ルがある場合には, そのファイルは強制的に削除され
る。古い tap.txt を保存しておく必要があるときには
あらかじめ名前を変更しておくこと。

ファイル design.sci の簡単な説明を図 9.10に示す。

FIR フィルタを設計するための関数eqfirを利用する。

frmagは周波数応答を計算する関数で、ゲインと対応す
る周波数を返す。これらを変数hmとfrに保存する。 

縦軸をデシベル表示になおす。

横軸をサンプリング周波数
に合わせる。

描画。

設計されたフィルタのタップ係数をフロッピーディ
スクに保存する。データを保存するファイルの名前
をtap.txtとする。

unix_w(’del a:\fir\tap.txt’);
hn=eqfir(9,[0 .1;.2 .3;.4 .5],[1 0 1],[1 1000 1]);
[hm,fr]=frmag(hn,256);
hm=20*log10(hm);
fr=fr*8000;
plot(fr(1:255),hm(1:255));
write(’a:\fir\tap.txt’,hn);

古いtap.txtを消去。

※要変更

図 9.10 FIR フィルタ設計プログラム (design.sci) の
説明

続いて, design.sciを修正して,各自に配布されたテー
プに含まれる雑音が消えるようにする。design.sciを開
くには,

A:\fir\design.sci

をダブルクリックすればよい (図 9.11)。ファイルをど

図 9.11 design.sciをエディタで開く

のように修正すれば良いかについては, 後で述べる。
ファイルの修正が終わったら必ずウインドウ上部の

メニューから

ファイル→上書き保存 (S)

を実行して変更後の内容を保存しておくこと。

ファイルの保存に成功したら, 再び design.sciを実行
する。画面に表示されたフィルタの性能が満足すべき

ものだったら次に進む。性能に問題があると思われる

場合は前に戻る。

ここで, ファイル design.sci のどこを変更する必要
があるかについて説明しておく。

変更を要するのは最初の行のみである。この行では

関数 eqfir を使って帯域阻止フィルタを設計している
のだが, この関数の第 1引数, 第 2引数, 第 4引数を設
計したいフィルタの特性に対応したものに書き換えな

ければならない。

関数 eqfir の引数の意味と注意事項について以下で
説明する。

第 1引数 フィルタの次数を指定する部分である。こ

の数値は整数でなければならない。一般に, フィ
ルタの次数が高いほど理論的にはフィルタは高性

能になる。しかし, 実際には, 次数を高くしすぎる
と, 計算の遅延時間が長くなる, メモリを大量に
消費する, 桁溢れや桁落ちの影響を受けやすくな
る, といった問題が生じる。一方, 次数が低すぎる
場合には, フィルタの設計上の性能がかなり低く
なってしまう。一般的に言えば, フィルタの性能
が同等であるならば, 次数は低ければ低いほどよ
い。各自でどの程度の次数が適切であるか試して

みること。なお, フィルタの次数が偶数と奇数の
場合で挙動が大幅に異なることを注意しておく。

第 2引数 フィルタの形状を指定する部分である。この

部分では, Scilabの行列の記法を使って, どの周波
数帯でフィルタの性能を指定するかを決める。

周波数帯を指定する際には, 周波数軸をいくつか
のたがいに重ならない領域に区切り, 各行の成分
がこれらの領域の左端および右端の周波数になっ

ている 2列の行列を作成する。この実験で作成し
たいフィルタは帯域阻止フィルタで, 性能を指定
したい領域は

• 低周波側の信号を通過させる領域
• 信号を遮断したい領域
• 高周波側の信号を通過させる領域

の 3個である。よって, 第 2引数は 3行 2列の行
列になる。

実験課題を達成するためには, 第 2引数の行列の
内容を諸君が取り扱わなければならない帯域阻止

フィルタに対応したものに書き換える必要がある。
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なお, 周波数軸は正規化されていて, 設計上の周波
数 1が実際のフィルタにおけるサンプリング周波
数 (この実験では 8kHz) に対応する。また, ディ
ジタルフィルタの周波数特性はナイキスト周波数

(サンプリング周波数の半分)を境にして対称にな
るので, フィルタを設計する際に周波数として 0.5
より大きい値を指定しても意味がない。

また, FIRフィルタは急峻な特性を持つフィルタ
を設計するには不向きであるので, 指定する領域
や特性を指定している領域にはさまれた「遷移領

域」の幅が狭すぎると設計がうまくいかないこと

がある。

第 3引数 第 2 引数において指定した領域において信
号を通過させるか遮断するかを指定する。値 1を
指定すると信号通過, 値 0を指定すると信号遮断
を指定したことになる。この部分は変更しなくて

よい。

第 4引数 この部分は「重み」と呼ばれるもので, 第 2
引数で指定した各領域がどのくらい重要であるか

を指定する部分である。この部分に指定される数

値は整数である。大きい重みが与えられたは理想

的な値に近い特性を持つようになるが, その場合,
小さい重みが与えられた領域の性能が犠牲になる。

図 9.10の第 1行目でどのようなフィルタの特性が指
定されているかを図 9.12に示す.

0 0.1 0.2 0.3 0.4

1
ゲイン

正規化周波数
0.5

領域1 領域2 領域3

値１を指定したところは
通過域になる。 

値０を指定したところは
阻止域になる。

遷移領域
周波数軸はサンプリング周波数
が横軸の１に対応するように正
規化されている。ナイキスト周
波数(0.5)以上の周波数について
特性を指定することはできない
ことに注意。

図 9.12 関数 eqfir におけるフィルタの特性の指定

希望する特性を持つフィルタが得られるまで, 何度
でも design.sci を変更して Scilabで実行すること。な
お, design.sci を実行すると以前作成した tap.txt は消
えてしまうので, 必要な場合は各自で名前を変えて保
存しておくこと。

なお, ファイルの編集には, Mule, メモ帳など,どの
ようなエディタを使ってもよい。

なお, Scilabのグラフィックスウィンドウに描画され
たグラフを印刷するには, グラフィックスウィンドウ上
部の File メニューから Printを選択すること。ここに
は Print(Scilab) と Print(Windows) の 2種類の印刷
用メニューがある。どちらを使ってもよい。また, グラ
フをファイルに保存しておくには, File メニューから
Export を選択する。

3.2.4 Code Composer Studioを用いた実行可能
プログラムの作成

本節では, Code Composer Studioを用いてC6711で
実行可能なプログラムを作成する方法について述べる。

3.2.4.1 Code Composer Studio の起動 Code
Composer Studioを起動するには,

スタート→プログラム (P)→Ti→CCStudio

を選択する (図 9.13)。図 9.13 のメニューが実行され

図 9.13 Code Composer Studioの起動

ると, 画面に図 9.14のようなロゴがあらわれ, 続いて
DSPボードが認識されたことを確認するウィンドウが
開く (図 9.15)。OK ボタンを押すと図 9.16 のように
Code Composer Studio が起動する。

3.2.4.2 プロジェクトファイルを開く プロジェクト

ファイルとは,プログラムを完成させるために必要とな
る一連の手続きを記述したファイルのことである。こ

こでは, プロジェクト名を fir とする。この実験ではフ
ロッピーディスクにあらかじめ用意されたプロジェク

トファイルを利用する。

このプロジェクトを開くには, Code Composer Stu-
dioの画面上端のメニューから
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図 9.14 Code Composer Studio の起動ロゴ

図 9.15 DSPボードの確認ウィンドウ

図 9.16 Code Composer Studioが起動したところ

Project→ Open...

を選択する (図 9.17)。すると図 9.18 にようなウィン
ドウがあらわれるので, そのウィンドウに表示された
fir.pjt をダブルクリックして選択する。
以上でプロジェクトを開く手順は終了する。

3.2.4.3 ソースプログラムの編集 先に Scilabを用
いて設計されたフィルタのタップ係数を実際のプログ

ラムに反映させるためには, ソースプログラムにこの
数値を書き込む必要がある。この実験で用いるソース

プログラムの名前は fir.c である。このファイルはフ
ロッピーディスクのフォルダ fir に保存されている。

fir.cを編集するためには, まずこれを開く必要があ
る。このファイルを開くには, Code Composer Studio
の画面上端のメニューから

File→ Open...

を選択する (図 9.19)。続いて, 画面にあらわれたウィ

ンドウでファイル fir.cをダブルクリックして選択する
(図 9.20)。すると, 図 9.21のように, ファイル fir.c が
表示されたウィンドウが開く。このウィンドウを使っ

てファイルの編集作業をおこなうことができる。

続いて, ソースプログラムのうち変更を要する箇所
について説明する。変更を要するのは 5行目, 10行目
の 2箇所だけである。

ソースプログラムの 5 行目では, LENGTH という
定数を使ってフィルタ長が宣言されている。この数値

を諸君が設計したフィルタのフィルタ長に変更する必

要がある。

続いて, 配列 fir_tap の値 ({} の中)に, 設計され
た FIRフィルタのタップ係数を書き込む。このために
は, まず設計済みのフィルタのタップ係数が保存され
たファイル

A:\fir\tap.txt

をダブルクリックして開く。続いてウインドウ左上の

端にマウスカーソルを合わせてからマウス左ボタンを

押し下げた状態にする。そして, そのままの状態でマ
ウスカーソルを下に移動させると, ファイルに書き込
まれた数値の部分がすべて反転表示されるようになる

(図 9.22)。この状態でマウスを右クリックし, あらわれ
たメニューの上から 3番目のコピー (C)にマウスカー
ソルを合わせてマウスをクリックする (図 9.23)。上述
の操作が終わったら, CodeComposerStudio内の fir.c
が開いているウインドウをクリックし, 9 行目の配列
fir_tapの値 ({}の中の数値)をすべて消してから {}
の内部にカーソルを合わせて (マウスカーソルを {}内
に入れてクリック) マウスを右クリックする。すると

図 9.17 プロジェクトを開く (1)

図 9.18 プロジェクトを開く (2)
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図 9.19 ソースプログラム fir.c を開く (1)

図 9.20 ソースプログラム fir.c を開く (2)

図 9.21 ソースプログラム fir.c を開く (3)

図 9.22 tap.txtの内容をコピー (1)

図 9.23 tap.txtの内容をコピー (2)

図 9.24のようなメニューがあらわれるので, この中か
ら pasteを選択する。すると, フィルタのタップ係数が
{}内に書き込まれる。さいごに, 個々の数値のあいだ
にコンマ (,)を入れる。ただし, {の直後と }の直前に
はコンマを入れないことと。また, 数値と数値のあい
だに改行が入っている場合にもコンマが 1個必要であ
ることに注意すること。変更後のファイルは, たとえ
ば図 9.25のようになる。変更がおわったら, 画面上端

図 9.24 fir.cへのタップ係数の書き込み (1)

図 9.25 fir.cへのタップ係数の書き込み (2)

のメニューから

File→ Save

を選択して, 編集後のファイルを保存する (図 9.26)。

図 9.26 変更後の fir.cの保存

3.2.4.4 コンパイル ソースプログラムの変更が終

わったら, プログラムをコンパイルして DSP に送る
ためのデータを作る。このためには, Code Composer
Studioの画面上端のメニューから

Project→ Rebuild All
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図 9.27 プログラムのコンパイル

を選択する (図 9.27). コンパイルに成功すると, 画面
下部のウインドウに

Build Complete,

0 Errors, 0 Warnings, 0 Remarks.

というメッセージが出る。この状態になったら, 作成
したプログラムを DSPで実行できる (図 9.28)。

図 9.28 コンパイルに成功した画面

コンパイル時にエラーや警告が出た場合には, ソー
スプログラム fir.cに問題があるので, ソースプログラ
ムを修正してから再度 Rebuild Allを実行すること。

3.2.5 実行可能プログラムのロードと実行

コンパイルが成功して実行可能プログラムが完成し

た後には, いつでもこのプログラムをロードして実行
することができる。だから, ソースプログラムを変更
した場合を除き, 1回コンパイルが成功すれば, それ以
降は再コンパイルは不要である。

3.2.5.1 実行可能プログラムのロード 実行可能プ

ログラムをロードするには, Code Composer Studioの
画面上部のメニューから

File→ Load Program...

を選択する (図 9.29)。すると図 9.30のようなウィンド
ウがあらわれるので, フォルダ Debugをダブルクリッ
クする。すると, ウィンドウの内容は図 9.31のように

変わる。このウインドウ内で fir.outをダブルクリック
すると, プログラムのロードが終了する。

図 9.29 実行可能プログラムのロード (1)

図 9.30 実行可能プログラムのロード (2)

図 9.31 実行可能プログラムのロード (3)

3.2.5.2 実行と停止 Code Composer Studio左端の
アイコンの中で, 人が走っているように見えるものが
プログラムの実行のアイコンである。ここをクリック

するとプログラムの実行が始まる (図 9.32)。プログラ
ム実行中は, DSPボード のオーディオ入力端子から入
力された信号が DSPによってリアルタイムで処理さ
れ, 結果がオーディオ出力端子に出力される。人が止
まっているように見える絵をクリックするとプログラ

ムが停止する。

プログラムを実行した後は, 停止することを忘れな
いこと。

3.2.6 フィルタの動作確認

フィルタの動作確認をするには, カセットテープレ
コーダのオーディオ出力端子を DSPボードのマイク
入力端子に接続し, DSPボードのオーディオ出力端子
をスピーカを接続して音楽を再生する。続いて,
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実行
停止

図 9.32 プログラムの実行と停止

1. フロッピーディスクドライブにフロッピーディス
クを挿入する

2. Code Composer Studioを起動する

3. Code Composer の File → Load Program... メ
ニューで fir.outを読み込む

4. Code Composer の 実行 ボタンを押す

という手順をおこなう。すると, 作成したフィルタに
よって処理された音ををスピーカで聞くことができる。

雑音がある程度消えていることが確認できれば測定

に進む。雑音が消えていない, あるいはスピーカから
音がまったく出ないときには,

• ケーブルの接続が正しいことを確認する
• プログラムを見直す
• DSPボード をリセットする

• DSPボード の電源を再投入する

• パソコンを再起動する
という順で確認作業および機材の再起動をおこない,な
お状況が好転しない場合は担当教官に申し出ること。

なお, これに続いてスペクトルアナライザを用いた
波形観測による波形観測をおこなう場合には, 再生音
が割れて聞こえないようにカセットテープレコーダの

ボリュームを調整するとよい (再生信号の電圧が過大
である場合がある)。また, 続いて波形観測をおこなう
場合には, 次節に述べる操作手順のうち, File→ Load
Program の部分と 実行 の部分は無視してよい。続い
て波形観測をおこなわない場合には, Code Composer
Studio の停止ボタンを押して DSPボードを停止して
から Code Composer Studio を終了する。

3.2.7 スペクトルアナライザを用いた波形観測

スペクトルアナライザを用いてDSPによって処理さ
れた後のスペクトルを観測するには, WaveSpectraお
よび CodeComposerStudio が起動されている状態で,

1. Code Composer の File → Load Program... メ
ニューで fir.outを読み込む

2. Code Composer の 実行 ボタンを押す

3. テープをあらかじめ決めた位置まで巻き戻す

4. カセットテープレコーダのオーディオ出力端子を
DSPボードのマイク入力端子に繋ぐ

5. DSPボードのオーディオ出力端子をパソコンのマ
イク入力端子に繋ぐ

6. WaveSpectraの録音ボタンを押す

7. 一定時間が経過したらWaveSpectraの停止ボタン
を押す (カセットテープレコーダのカウンタを利
用するとよい)

という一連の作業をおこなう。フィルタの特性を見るた

めには, スペクトルのピーク値のみを表示するとよい。

測定値のグラフをファイルに保存するためには, スク
リーンキャプチャソフトウェアであるWinShot 3 (フ
リーウェアである)を使う4。

WinShotを起動するには, デスクトップ左端にある
WinShotというアイコンをダブルクリックする。する
と, タスクバー右端に WinShot のアイコンがあらわ
れる。

続いてWaveSpectorのウィンドウをキャプチャする
わけであるが, このためには,

1. WaveSpectraのウィンドウをアクティブにする (ウ
ィンドウのどこかでマウス左ボタンを押す)

2. タスクバー右端のWinShotのアイコンを右クリッ
クする

3. JPEG保存→アクティブウィンドウを選択する

という手順をおこなう (図 9.33) 。すると, デスクトッ
プに画像データが保存される。ファイル名は ws00.jpg
から始まり, 番号が自動的に増えてゆく。

なお, フィルタの特性を見るためには, DSPボード
によって処理される前のスペクトルデータも必要であ

る。このデータを取るためには,カセットテープレコー
ダのオーディオ出力端子をパソコンのマイク入力端子

に繋ぎ換えてから, 上記と同様の手順をおこなう。

3http://www.woodybells.com/
4WaveSpectra にもグラフを保存する機能があるが, データを

bitmap形式でしか保存できないという制限があり, bitmap形式の
データはファイルサイズが大きくなるので, ここでは使用しない。
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図 9.33 WinShotによる画像の保存

3.2.8 周波数特性の測定

フィルタの周波数特性を測定するには, 図 9.34のよ
うにフィルタの入力側に発振器を接続し, 周波数を変
えながら入力電圧と出力電圧をスイッチで切り換えな

がらディジタルマルチメータあるいはディジタルテス

ターで測定すること。発振器の出力電圧は 1V程度に
する。

ある周波数におけるフィルタのゲインは,

ゲイン = 20 log10

出力電圧
入力電圧

(9.5)

によって計算される。ゲインの単位は dB(デシベル)で
ある。位相特性は測らなくてよい。

この実験で使用する DSPボード は直流電流を遮断
する設計になっているので, あまり低い周波数につい
てデータを取ることは無意味である。また, ナイキスト
周波数 (4kHz)以上の周波数の信号は DSPボード に
付属している低域通過フィルタで減衰してしまうので,
あまり高い周波数についてもデータを取ることは無意

味である。

4. データ解析

• フィルタの周波数特性の設計値と実測値を比較し,
特性にずれがある場合にはずれの要因について検

討せよ。

• 実測されたフィルタの周波数特性とスペクトルア
ナライザで観測された波形における雑音の減衰量

を比較せよ。

電源ユニット
100V電源へ

パソコンパラレルポートへ

発振器

切り替えスイッチ

ディジタルマルチメーターあるいは
ディジタルテスター

図 9.34 周波数特性の測定
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参考

同軸ケーブル, ピンプラグ, ミニプラグの構造

オーディオ機器の出力端子どうしを接続するために

使われているケーブルの多くは, 同軸ケーブルと呼ば
れるものである。このケーブルは, 外見上は 1本だけの
線なのだが, 内部には芯線とグランド線の 2本の線が
通っている。芯線とグランド線のあいだは絶縁材で絶

縁されている。図 9.35に同軸ケーブルの構造を示す。

芯線

メッシュ状のシールド線
(芯線とは絶縁されている)絶縁材

被膜

図 9.35 同軸ケーブルの構造

機器同士を接続して電気回路を閉じるためには線が

2本必要である。これに対応して, オーディオ機器の出
力端子 (ピンジャックやミニジャックなど) にも 2本の
線に対応する部分があり, それらに挿入されるピンプ
ラグやミニプラグも 2本の線に対応する部分を持って
いる。

ピンプラグの構造を図 9.36に示す。図 9.36におい
て, オーディオ機器との接続部の中央のピン Aと外縁

部の円筒形の金属部品Bは絶縁材によって絶縁されて

いる。部品Aは同軸ケーブルの芯線A’と接続され, 部
品 Bは同軸ケーブルのシールド線 B’と接続される。

A A’
B

B’

図 9.36 ピンプラグの構造

ミニプラグの構造を図 9.37に示す。図 9.37におい
て, オーディオ機器との接続部のピンは絶縁材で先端
の部品 Aと根本の部品 Bに区切られている。部品 A
は同軸ケーブルの芯線 A’と接続され, 部品 Bは同軸
ケーブルのシールド線 B’と接続される。

絶縁

A B A’ B’

図 9.37 ミニプラグの構造

これにより, オーディオ機器の出力信号をディジタ
ルマルチメータやスペクトルアナライザで測定したい

ときには, 図 9.38のようなケーブルを作製しておけば
よいことがわかる。図 9.38のようなケーブルは実験室
にあらかじめ用意されている。

図 9.38 オーディオ機器に接続する測定用ケーブル

スペクトルアナライザの縦軸の表示について

観測された時間信号を x(t), そのフーリエ変換を
X(w)としたとき, フーリエ変換の定義

X(w) =
1
2π

∫
x(t) exp[−jwt]dt

により, 信号 X(w)の単位は, 信号 x(t)の単位に時間
を乗じたものになる。たとえば, 信号 xの単位が電圧

[V]で, 時間の単位が秒 [s]であるときには, X の単位

は [Vs]となる。ところで, スペクトルを表示するとき
には縦軸を対数軸に取ることが多いのであるが, 対数
を取るためには, その対象となる変数が無次元量になっ
ていないと都合が悪い。そこで, スペクトルアナライ
ザでは, 形式的に, 測定信号が 1Vsで規格化されている
とみなして, 機械的に X(w)の対数を取り, 慣習的に,
縦軸の単位を [dBV]と表示することが多い。
一方, 縦軸の単位を [dB]で表示するものもある。本

実験で利用しているWaveSpectraは後者にあたる。た
だし, 縦軸の単位を [dB]と表示することは, 単位 [dB]
の意味を考えると, 必ずしも適切とはいえない。
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